I got a Bitcoin fork from forkgen. I have 2 nodes running which have fully synced with the Bitcoin blockchain up to the fork . (507548)

Commands like getnetworkinfo, getpeerinfo, getblockchaininfo, getblocktemplate, getmininginfo and getwalletinfo all seem to give valid responses.

I installed pool software (UNOMP) which also starts without errors or complaints. Below is some info from when the pools starts:

Pool bitcoin euro Thread 1 started for mycoin [MYC] {sha256}
Network : Mainnet
Detected Reward Type: POW
Current BlockHeight: 507549
Current Connect Peers: 1
Current Block Diff: 1
Network Difficulty: 2603077300218.593
Network HashRate: 17.13undefined

The Current BlockHeight: 507549 is the fork block + 1

When we connect an Antminer to the pool and try to mine some coins, the coin daemon shows the following errors in debug.log:

ERROR: ProcessNewBlock: AcceptBlock FAILED
ERROR: ReadBlockFromDisk: OpenBlockFile failed for CBlockDiskPos(nFile=-1, nPos=0)
ERROR: AcceptBlock: bad-cb-, block in coinbase ( 16)

The mining pool software logs this:

Pool mycoin Thread 2 Submitted Block using submitblock successfully to daemon instance(s)
Pool mycoin Thread 2 We thought a block was found but it was rejected by the daemon, share data: {“job”:”d9″,”ip”:”163.158.171.154″,”port”:3008,”worker”:”F6QQ9CHFm3cA79TgWQjHSxqUbp21jz4J5n”,”height”:507549,”blockReward”:1250000000,”difficulty”:8,”shareDiff”:”16.71488033″,”blockDiff”:1,”blockDiffActual”:1,”coinbaseBuffer”:[1,0,0,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,255,255,255,255,76,3,157,190,7,4,25,27,128,90,8,250,190,9,9,90,128,26,226,67,183,187,112,240,49,176,255,28,251,64,136,122,32,3,152,,70,33,66,163,1,226,7,28,141,216,31,1,0,0,0,0,0,0,0,112,0,0,8,0,0,211,155,13,47,1,111,0,1,83,116,114,97,116,117,9,47,0,0,0,0,3,0,0,0,0,0,0,0,0,38,6,36,170,33,169,237,226,246,28,63,113,209,222,253,63,169,153,223,163,5,83,117,92,5,6,137,121,153,98,180,139,235,216,54,151,78,140,249,96,192,194,73,0,0,0,0,25,118,169,20,1,82,192,234,6,40,8,237,64,65,5,249,234,186,114,15,23,26,239,186,136,172,32,188,190,0,0,0,0,0,25,118,169,20,54,26,205,239,163,90,35,71,155,143,215,203,211,43,236,194,33,45,17,155,136,172,0,0,0,0],”headerHash”:[133,188,50,11,73,241,7,28,189,88,87,205,133,45,146,207,134,119,81,158,68,148,183,47,9,194,80,15,0,0,0,0],”blockBigNum”:{},”blockHash”:”000000000f50c2092fb794449e517786cf922d85cd5758bd1c6bf1490b32bc85″,”blockHashInvalid”:”000000000f50c2092fb794449e517786cf922d85cd5758bd1c6bf1490b32bc85″,”time”:1518345018}

below is the getblockchaininfo output:

{
  "chain": "main",
  "blocks": 507548,
  "headers": 507548,
  "bestblockhash": "00000000000000000005dbc5a2b71f0173e27e9ea3df4eb3d7d7d9667f134511",
  "difficulty": 2603077300218.593,
  "mediantime": 1517726132,
  "verificationprogress": 1,
  "chainwork": "00000000000000000000000000000000000000000106cea41be31a18bda5f97b",
  "pruned": false,
  "softforks": [
    {
      "id": "bip34",
      "version": 2,
      "reject": {
        "status": true
      }
    },
    {
      "id": "bip66",
      "version": 3,
      "reject": {
        "status": true
      }
    },
    {
      "id": "bip65",
      "version": 4,
      "reject": {
        "status": true
      }
    }
  ],
  "bip9_softforks": {
    "csv": {
      "status": "active",
      "startTime": 1462060800,
      "timeout": 1493596800,
      "since": 419328
    },
    "segwit": {
      "status": "active",
      "startTime": 1479168000,
      "timeout": 1510704000,
      "since": 481824
    }
  }
}

What could be the cause of this problem? Any ideas how to solve this? Is this a problem with the forked code, a misconfiguration of the pool or does the mining software needs a different configuration?

Forkgen is not really responding to support requests. Do others have their forked coins by Forkgen working?



Source link
Blockchain – Crypto – Currency infomation
thanks you RSS link
( https://bitcoin.stackexchange.com/questions/70601/block-height-mismatch-in-coinbase-when-mining)

LEAVE A REPLY

Please enter your comment!
Please enter your name here